Настройка маршрутизатора cisco как dhcp клиента

Step 2:

Step 2: Now you will proceed to enable a logical interface inside the router, this type of interfaces are very useful since these are always on if the router is on too. But it is good practice to always make sure that the logical interface is turned on.To do this we will place the following commands in the global configuration:

Int loopback 1

Ip address 1.1.1.1 255.255.255.255

No shutdown

Paso 2: Ahora se procederá a habilitar una interfaz lógica dentro del router, este tipo de interfaces son muy útiles ya que estas siempre están encendidas media vez el router este encendido. Pero es una buena práctica siempre asegurarnos de que la interfaz lógica esta encendida. Para ello colocaremos los siguientes comandos en la configuración global:

Int loopback 1

Ip address 1.1.1.1 255.255.255.255

No shutdown

Настройка централизованного DHCP сервера с помощью Cisco Packet Tracer

В этой видео инструкции рассматривается процесс настройки централизованного DHCP сервера в программе Cisco Packet Tracer.

  • как настроить пулы динамических IP адресов для различных сегментов локальной сети,
  • как настроить рабочую станцию на получение динамического IP адреса,
  • как проверить наличие получения динамического IP адреса рабочей станцией.

Новые команды для настройки маршрутизатора для получения пула динамических IP адресов у централизованного DHCP сервера.

Для примера рассматривается роутер R1

Настройки производятся в режиме глобальной конфигурации:

R1(config)#interface fastEthernet 0/1 — заходим в настройки интерфейса к которому подключен компьютер получающий динамический IP адрес

R1(config-if)#ip helper-address 192.168.30.11 указывается IP адрес централизованного DHCP сервера.

8.1.3.3 Packet Tracer – Configuring DHCPv4 Using Cisco IOS

From year to year, Cisco has updated many versions with difference questions. The latest version is version 6.0 in 2018. What is your version? It depends on your instructor creating your class. We recommend you to go thought all version if you are not clear. While you take online test with netacad.com, You may get random questions from all version. Each version have 1 to 10 different questions or more. After you review all questions, You should practice with our online test system by go to «Online Test» link below.

Version 5.02 Version 5.03 Version 6.0 Online Assessment
Chapter 8 Exam Chapter 8 Exam Chapter 8 Exam Online Test
Next Chapter
Chapter 9 Exam Chapter 9 Exam Chapter 9 Exam Online Test
Lab Activities
8.1.3.3 Packet Tracer – Configuring DHCPv4 Using Cisco IOS
8.3.1.2 Packet Tracer – Skills Integration Challenge

Листинг команд настройки маршрутизатора R1, на котором «поднят» DHCP сервер, следующий:

R1(config)#interface Ethernet 0/1/0

R1(config-if)#ip address 172.33.56.1 255.255.255.0

R1(config)#ip dhcp excluded-address 172.33.56.1

R1(config)#ip dhcp excluded-address 172.33.56.254

R1(config)#ip dhcp pool R1SW6

R1(dhcp-config)#network 172.33.56.0 255.255.255.0

R1(config)#do sh ip prot

Routing Protocol is «bgp 1»

Outgoing update filter list for all interfaces is not set

Incoming update filter list for all interfaces is not set

R1(config)#router bgp 1

R1(config-router)#do sh ip route

172.33.0.0/24 is subnetted, 1 subnets

C 172.33.56.0 is directly connected, Ethernet0/1/0

R1(config-router)#network 172.33.56.0 mask 255.255.255.0

Step 14:

Step 14: Finally on a laptop select the option of Desktop and Ip Configuration, then select the DHCP option to receive the IP address automatically.

It should be remembered that if you do not give the address automatically you can implement the recommendations in Step 5.

Paso 14: Por último entraremos a un dispositivo final para seleccionaremos la opción de Desktop y Ip Configuration, luego seleccionaremos la opción de DHCP para recibir la dirección Ip de manera automática.

Se debe de recordar que si no da al principio la dirección de manera automática puede implementar las recomendaciones del Paso 5.

DHCP Relay¶

If you want your router to forward DHCP requests to an external DHCP server
you can configure the system to act as a DHCP relay agent. The DHCP relay
agent works with IPv4 and IPv6 addresses.

All interfaces used for the DHCP relay must be configured. See
https://wiki.vyos.net/wiki/Network_address_setup.

Configuration

set service dhcp-relay interface <interface>

Enable the DHCP relay service on the given interface.

set service dhcp-relay server <server>

Configure IP address of the DHCP <server> which will handle the relayed
packets.

set service dhcp-relay relay-options relay-agents-packets discard

The router should discard DHCP packages already containing relay agent
information to ensure that only requests from DHCP clients are forwarded.

Example

  • Listen for DHCP requests on interface .
  • DHCP server is located at IPv4 address 10.0.1.4.
  • Router receives DHCP client requests on and relays them to the server at 10.0.1.4.

DHCP relay example

The generated configuration will look like:

show service dhcp-relay
    interface eth1
    server 10.0.1.4
    relay-options {
       relay-agents-packets discard
    }

Options

set service dhcp-relay relay-options hop-count <count>

Set the maximum hop <count> before packets are discarded. Range 0…255,
default 10.

set service dhcp-relay relay-options max-size <size>

Set maximum <size> of DHCP packets including relay agent information. If a
DHCP packet size surpasses this value it will be forwarded without appending
relay agent information. Range 64…1400, default 576.

set service dhcp-relay relay-options relay-agents-packet <append | discard | forward | replace>

Four policies for reforwarding DHCP packets exist:

  • append: The relay agent is allowed to append its own relay information
    to a received DHCP packet, disregarding relay information already present in
    the packet.
  • discard: Received packets which already contain relay information will
    be discarded.
  • forward: All packets are forwarded, relay information already present
    will be ignored.
  • replace: Relay information already present in a packet is stripped and
    replaced with the router’s own relay information set.

[править] Настройка DHCP snooping на коммутаторах ProCurve

Включить DHCP snooping:

sw2(config)# dhcp-snooping

Включить DHCP snooping в VLAN, которые должны быть защищены с его помощью:

sw2(config)# dhcp-snooping vlan 25

Настройка доверенных и ненадёжных портов

По умолчанию на коммутаторе все порты ненадёжные, поэтому доверенные порты надо явным образом указывать.

Указать доверенные порты:

sw2(config)# dhcp-snooping trust a1

Настройка авторизованного DHCP-сервера

После того как порт указан как доверенный, сообщения от любого DHCP-сервера, который подключен к этому порту передаются.
Для того чтобы указать IP-адреса конкретных DHCP-серверов, которым разрешено работать в сети, необходимо настроить список авторизованных DHCP-серверов.

Максимальное количество DHCP-серверов в списке — 20.

(Опционально) Указать адрес авторизованного DHCP-сервера, доступного через доверенный порт:

sw2(config)# dhcp-snooping authorized-server 192.168.25.254

После указания авторизованных серверов коммутатор не будет отбрасывать сообщения DHCP-сервера, если выполняются оба условия:

  • сообщение пришло на доверенный порт,
  • адрес сервера указан с списке авторизованных DHCP-серверов.

Проверка соответствия MAC-адресов

По умолчанию, после включения DHCP snooping, на коммутаторе включена проверка соответствия MAC-адресов.
Коммутатор проверяет соответствие MAC-адреса в DHCP-запросе MAC-адресу клиента.
Если они не соответствуют, то коммутатор отбрасывает пакет.

При необходимости можно отключить эту проверку:

switch(config)# no dhcp-snooping verify mac

Настройка опции 82

С опцией 82 связаны две настройки:

  • Настройка значения remote ID;
  • Настройка политики обработки пакетов с опцией 82.

Настройка remote ID:

sw2(config)# dhcp-snooping option 82 remote-id 

Значения remote ID:

  • mac — MAC-адрес коммутатора (значение по умолчанию);
  • subnet-ip — IP-адрес VLAN, который получил DHCP-запрос;
  • mgmt-ip — IP-адрес коммутатора.

Настройка политики обработки пакетов с опцией 82:

sw2(config)# dhcp-snooping option 82 untrusted-policy 

Значения политики:

  • drop — отбросить пакет;
  • keep — коммутатор отправляет пакет с сохранением значения опции 82;
  • replace — коммутатор отправляет пакет, но заменяет значение опции 82.

Отключить вставку опции 82:

switch(config)# no dhcp-snooping option 82 

Просмотр настроек и проверка работы DHCP snooping

Просмотр настроек DHCP snooping:

sw2(config)# show dhcp-snooping

 DHCP Snooping Information

  DHCP Snooping              : Yes
  Enabled Vlans              : 1 10 25 30
  Verify MAC                 : Yes
  Option 82 untrusted policy : replace
  Option 82 Insertion        : Yes
  Option 82 remote-id        : mac

  Store lease database : Not configured

  Authorized Servers
  ------------------
  192.168.25.254


  Port  Trust
  ----- -----
  A1    Yes  
  A2    No   
  A3    No   
  A4    No   
  A5    No   
.......

Просмотр статистики DHCP snooping:

sw2(config)# show dhcp-snooping stats

 Packet type  Action   Reason                        Count
 -----------  -------  ----------------------------  ---------
 server       forward  from trusted port              15
 client       forward  to trusted port                9
 server       drop     received on untrusted port     3
 server       drop     unauthorized server            0
 client       drop     destination on untrusted port  0
 client       drop     untrusted option 82 field      13
 client       drop     bad DHCP release request       0
 client       drop     failed verify MAC check        0

Просмотр базы данных привязки DHCP для коммутатора sw2:

sw2(config)# show dhcp-snooping binding

  MacAddress    IP              VLAN Interface Time Left
  ------------- --------------- ---- --------- ---------
  00163e-000101 192.168.10.10   10   A5        562      
  00163e-000103 192.168.30.10   30   A5        569      

Просмотр базы данных привязки DHCP для коммутатора sw1:

sw1(config)# show dhcp-snooping binding 

  MacAddress    IP              VLAN Interface Time Left
  ------------- --------------- ---- --------- ---------
  00163e-000101 192.168.10.10   10   1         525      
  00163e-000103 192.168.30.10   30   7         532      

DHCP snooping и DHCP-ретранслятор

Настройки опции 82 с DHCP snooping перекрывают любые глобальные настройки указанные при настройке коммутатора для работы DHCP-ретранслятором.

Описание процедуры настройки коммутаторов ProCurve для работы DHCP-ретранслятором можно прочитать на странице Опция 82 DHCP.

Если DHCP snooping не настроен в VLAN, то для него применяются глобальные настройки.

Поиск неисправностей

Включение debug:

sw2# debug dhcp-snooping 

В прошивках старше K.15

sw2# debug security dhcp-snooping 

Если необходимо вывести сообщения отладки в текущую сессию:

sw2# debug destination session

Если необходимо отправлять сообщения на log-сервер (log-сервер должен быть настроен командой logging <IP-адрес>):

sw2# debug destination logging

Step 1:

Step 1: First configure the DHCP service on the router, sowe will first enable the two interfaces and place their respective IP addresses with their Subnet Mask.

To do this, the following commands will be written in global configuration for the R1 router:

Int Fa0/0

Ip address 172.16.0.1 255.255.255.0

No shutdown

Int Fa0/1

Ip address 172.16.1.1 255.255.255.0

No shutdown

Do write memory

Paso 1: De primero configuraremos el servicio DHCP en el router, para ello de primero habilitaremos las dos interfaces y le colocaremos sus respectivas direcciones IP con sus Subnet Mask.

Para ello se escribirán los siguientes comandos en configuración global para el router R1:

Int Fa0/0

Ip address 172.16.0.1 255.255.255.0

No shutdown

Int Fa0/1

Ip address 172.16.1.1 255.255.255.0

No shutdown

Do write memory

DHCPv6 relay¶

Configuration

set service dhcpv6-relay listen-interface <interface>

Set eth1 to be the listening interface for the DHCPv6 relay.

Multiple interfaces may be specified.

set service dhcpv6-relay upstream-interface <interface> address <server>

Specifies an upstream network <interface> from which replies from <server>
and other relay agents will be accepted.

Example

  • DHCPv6 requests are received by the router on listening interface
  • Requests are forwarded through as the upstream interface
  • External DHCPv6 server is at 2001:db8::4

DHCPv6 relay example

The generated configuration will look like:

commit
show service dhcpv6-relay
    listen-interface eth1 {
    }
    upstream-interface eth2 {
       address 2001:db8::4
    }

Options

set service dhcpv6-relay max-hop-count ‘count’

Set maximum hop count before packets are discarded, default: 10

set service dhcpv6-relay use-interface-id-option

If this is set the relay agent will insert the interface ID. This option is
set automatically if more than one listening interfaces are in use.

show dhcpv6 relay-agent status

Show the current status of the DHCPv6 relay agent:

restart dhcpv6 relay-agent

Restart DHCPv6 relay agent immediately.

Настройка DHCP на оборудовании Cisco

3 минуты чтения

Друг, наша предыдущая статья была посвящена рассказу о том, что из себя представляет протокол DHCP (Dynamic Host Configuration Protocol). Сегодня мы расскажем, как его настроить на оборудовании Cisco.

Маршрутизатор Cisco, работающий под управлением программного обеспечения Cisco IOS, может быть настроен на работу в качестве DHCP сервера. Сервер назначает и управляет адресами IPv4 из указанных пулов адресов в маршрутизаторе для DHCP клиентов.

Исключение адресов IPv4

Маршрутизатор, работающий как DHCP сервер, назначает все адреса IPv4 в диапазоне (пуле), если не настроен на исключение определенных адресов. Как правило, некоторые IP адреса из пула принадлежат сетевым устройствам, таким как маршрутизаторы, сервера или принтеры, которым требуются статические адреса, поэтому эти адреса не должны назначаться другим устройствам. Чтобы их исключить, используется команда ip dhcp excluded-address. При помощи этой команды можно исключить как один единственный адрес, так и диапазон адресов, указав из него первый и последний.

Рассмотрим на примере, в котором исключим из раздачи адрес 192.168.1.254 и адреса с 192.168.1.1 по 192.168.1.9

Настройка DHCP пула

Настройка DHCP сервера включает в себя определение пула адресов, которые будут раздаваться. Для создания пула используется команда ip dhcp pool . После этого необходимо ввести две обязательные команды – network [маска/длина_префикса] для указания сети из которой будут раздаваться адреса и default-router для указания шлюза по умолчанию (можно ввести до 8 адресов).

Также можно использовать дополнительные команды – например, указать DNS сервер (команда dns-server ), доменное имя (команда domain-name ), NetBIOS WINS сервер (команда netbios-name-server), а так же время аренды адреса (команда lease , сначала указываются дни, затем через пробел часы, а затем минуты). По умолчанию время аренды выставляется 1 день.

Чтобы выполнить проверку можно использовать команду show ip dhcp binding, которая показывает список всех IP адресов и сопоставленных с ними MAC адресов, которые были выданы DHCP сервером. Также есть команда show ip dhcp server statistics, используя которую можно увидеть статистику DHCP сервера, включая информацию об отправленных и полученных DHCP сообщениях. Ну и если клиентом является ПК с ОС Windows, то информацию можно посмотреть через командную строку, введя команду ipconfig /all, а для пользователей Linux подойдет команда ifconfig.

Ретрансляция DHCP (DHCP Relay)

В сложной иерархической сети серверы обычно находятся не в той же сети, что и клиенты. В результате если DHCP сервер находится в другой сети, то до него не смогут доходить запросы от клиентов, поскольку маршрутизаторы не пересылают широковещательные сообщения. Чтобы решить эту проблему нужно воспользоваться командной ip helper-address , которую нужно ввести на маршрутизаторе в режиме конфигурации интерфейса, чтобы он перенаправлял broadcast сообщения от DHCP клиентов уже в виде unicast к DHCP серверу, находящемуся в другой сети.

Настройка роутера как DHCP клиента

Иногда роутер сам должен получить IP адрес по DHCP, например от интернет-провайдера. Для этого нужно в режиме конфигурации интерфейса ввести команду ip address dhcp, после чего интерфейс будет пытаться получить адрес от DHCP сервера.

Пожалуйста, расскажите почему?

Нам жаль, что статья не была полезна для вас Пожалуйста, если не затруднит, укажите по какой причине? Мы будем очень благодарны за подробный ответ. Спасибо, что помогаете нам стать лучше!

Подпишитесь на нашу еженедельную рассылку, и мы будем присылать самые интересные публикации Просто оставьте свои данные в форме ниже.

Добавить комментарий

Ваш адрес email не будет опубликован. Обязательные поля помечены *

Adblock
detector